Hybris server startup failes with older hybris versions on MAC Catalina

Error:

1
/bin/platform/tomcat/bin/./wrapper-macosx-universal-32: Bad CPU type in executable

Reason:

Tomcat version doesnt has 64 bit version wrapper

Solutions:

1) Replace tomcat directory

  • Download latest version hybris(eg: 1905).
  • Unzip , then copy the tomcat folder from bin directory.
  • Replace the workspace platform/tomcat directory with the new one.

2) Migrate to latest hybris version.